PDA

View Full Version : Index Out of Range


Ron@AMBestInspServ.com
01-20-2011, 12:10 PM
Reciently after compling my forms for Pocket 3D on my PC running 3D Version 11 and installing the Group Form on my IPAQ running Mobile 5.0, I get the following error everytime I try to bring up the form to do an inspection: Error Initalialize Report: Index Out of Range.

After reading several postings I assumed it might be a memory problem in my IPAQ Device. I have 28 Forms in my Forms Group. If I remove 4 Forms my IPAQ opens the Inspection Group Form without problem. But once I install one more form to the Group, the same error comes up.

This issue did not seem to occure untill after I chose not to apply changes to the forms after finishing a report in which changes were made while closing 3D.

Here is some information about my Form Group:

This shorten form works every time.
Forms - 24, Headings - 744, SubHeadings - 1898, Menu Items - 32497
Total Size of Form - 12081188, Compressed Size - 3113912

This is the full form, will not work now with 25 forms added.
Forms - 28, Headings -759, SubHeadings - 2024, Menu Items - 33259
Total Size of Form - 12339162, Compressed Size - 3181611

Once again, all 28 forms would work fine and then suddenly it stopped. I can understand it it were a memeory problem, deleting one form might correct an issue, but why it takes 4 forms, I don't know.

Here is some information about my IPAQ Mobile 5.0

The size of the full Group File Pocket 3D File is: 8,146kb.
Pocket 3D is the only application running on my IPAQ. No previous inspecitons are stored on the IPAQ. Only current inspection being worked on is on the device.

Here is my IPAQ Memory Availability with the Pocket 3D and Group File on the IPAQ.

Storage: Total 135.33mb, In Use: 14,49MB, Free: 120.84MB

Program: Total 56.59MB, In Use: 16.37MB, Free: 40.22MB

Any help would be appreciated.

Ron

Donna
01-20-2011, 01:48 PM
When you use Pocket3D and click off a menu item, does it fill with a solid square? Or a check mark? If it's a check mark, then you have an older Pocket3D for version 11 installed. If it's a solid square, then you have the last release. You might use that to verify that you at least have the final Pocket3D version installed.

If you are running the last release and still have a problem, you may want to send a ticket to support and use the attach file button to include your 3DF form backup so they can check into it further.

Ron@AMBestInspServ.com
01-20-2011, 02:38 PM
It has a Check Mark. I will uninstall Pocked 3D and install the version that came with the latest Version 11.

Thanks - - - I will let you know.

Duffy
01-29-2011, 11:11 PM
What did you do regarding the Read Report error. Index out of range exception is also showing up on the hp iPAQ screen when trying to open new form set I created. The old form sets are working fine.

Thanks for any help.